Windows 11 Networking Not All Computers Showing

I was having an issue where only a 3 of my networked computers were showing in the Windows Network Neighborhood (or at least they used to call it Network Neighborhood).

All computers on the network were visible from all my Mac and Linux computers and running software such as LanScan showed everything proudly announcing itself on the network.  So the problem pretty clearly was with Windows 11.

This is a blog where I wish I specified a FIX to the problem but the truth is, I’m not sure what fixed the problem, but this blog may not be a total waste to anyone else with this problem. 

First of all, I’m not new to the geek stuff, but I am newly returned to Windows.  I bought an Acer Aspire 5 laptop specifically to run a program called Vectric VCarve Desktop for my CNC machine.  Also my CNC machine firmware can only be updated from a Windows computer. Also since I design my SVG files on a Mac and store them on a couple of servers  I HAVE TO HAVE NETWORK ACCESS WITH MY WINDOWS LAPTOP WHILE I’M IN MY WORKSHOP TRYING TO CNC SOMETHING.

Let’s dig in.
As I started to say, I’m not new to networking but this one had me stumped.  I did all the stupid things first like rebooting the routers, the Windows laptop, all my Mac computers before trying to dig into Windows.

Also I should note that while several computers were not showing in the network pane I could open a Windows Remote session (Win key + R) and connect to them with this command:

\\ComputerName\Share

I could then map the drive and access the contents.  What in the actual hell?  Clearly they were on the network, clearly they were accessible, but they wouldn’t show up in the network pane.

I did all the recommended stuff in Windows such as:

  • Turn on Network Discovery and Network Sharing
  • Set to Private Network
  • Turned off Firewalls
  • Checked the WorkGroup name
  • Reset Network
  • Updated and rolled back my network drivers
  • Tried it on the Ethernet adapter and turned off WiFi
  • Updated to Windows 11 Pro (I was going to do that anyway)
  • Here’s the best one.  I upgraded the NVME drive but still had the original one.  I put it back in as it was upgraded from a very early, clean state of owning the laptop thinking an update borked my networking. Even that didn’t work.
  • And 20 other things…………

Nothing worked.  Very frustrating.  So here’s my situation.  3 computers are visible (4 counting the Windows Computer itself).  It should be more like7 or 8 and possibly 12 if some computers aren’t asleep.  But I could only see 3 and then I mapped access to 4.

Windows SMB Fouled Up Networking (click pic to enlarge)

So I spent a day and a half messing with this (I was sick so just laying around anyway). I finally gave up and while networking was on my mind I decided to do some maintenance to my servers.  I have 3 Raspberry Pi backup servers and I decided to update and upgrade them and reboot them.  The one in my workshop shed is a Raspberry Pi that runs OpenMediaVault.  Here’s where it gets WEIRD.  And it is worthy to note that OMVPI is already visible on the network in Windows.

I’m on a Mac Mini and right next to me is the Windows laptop open to the Network pane.  I have SSH’d into my OpenMediaVault server and updated it. The very second I reboot the OMVPI computer, EVERY COMPUTER ON MY NETWORK AUTOMAGICALLY APPEARS IN THE WINDOWS NETWORK NEIGHBORHOOD.  Nine computers visible where there were previously three.

Hoomp There It Is

There was no IP address conflict, all computers pointed to the same DNS server………..I have no clue why rebooting that computer caused the networking problem to fix itself……….but it did.  Doing a Network Reset on Windows 11 runs several commands that release the IP, renew the IP and flush the DNS Cache.  If it were a DNS problem it should have resolved itself with the Network Reset action.

I’m stumped.  And most of all I’m angry at Windows.  It was, and always has been a sub-par operating system.  If I didn’t own a $4000 CNC machine that needed it, I wouldn’t have it at all.  I very clearly remember now why I ditched Windows XP and then Windows 7 for Linux and Mac, and I never looked back.

And say what you want, you have to have a background in Windows to use it.  It isn’t intuitive at all.  As the old joke goes……”How do you turn off a Windows Computer?”.  Answer:  First hit the Start Button.

Anyway I hope this helps someone who has a similar issue even if that person is me a year from now when it happens again and I forgot what I did to fix it.

#Let’s Go Bill Gates

#FBG

Leave a Reply

Your email address will not be published.